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Getting started
This chapter explains the information you need to log on and use the Automated Lightning Mapping System (ALMS).  ALMS allows you to download near real time lightning location information from the Bureau of Land Management lightning data server on the Internet and then view that data using ArcMap 8.3. Topics include:

• 
Before you begin

• 
Installing ALMS

• 
Terms and concepts.

Before you begin
Before using ALMS, you must feel confident that:

· You have requested “Administration” privelege to log into the target client PC where you will be installing ALMS. 

· You are familiar with your personal computer and functions keys, and understand personal computer concepts.

· You are familiar with Windows NT, Windows 2000 or Windows XP and can log on and log off.

· You have basic skills using ArcGIS 8.3 or “ArcMAP” and an Internet browser.

· You have assured ArcGIS 8.3 or “ArcMAP” starts and runs on your target client PC.

Software and hardware requirements
You must have the following hardware and software to run ALMS:

	Item
	Minimum Requirement
	Recommended 

	Operating System
	Windows NT, Windows 2000, Windows XP
	same

	Internet Browser
	MS Internet Explorer 5.0 or newer
	same

	Internet connection
	9600 or higher
	56K or higher

	mapping software
	ArcGIS 8.1 or higher
	ArcGIS 8.3

	CPU
	Pentium
	Pentium 200

	monitor color support
	256
	65,536

	monitor resolution
	640 x 480
	same

	RAM
	32 MB
	64 MB

	hard disk space available
	30 MB
	same

	mouse
	yes
	same

	printer
	any - windows compatible
	color laser


Installing ALMS
This section outlines the basic instructions to install ALMS for Windows NT, 2000 and XP operating environments. Before starting the installation process, close all other applications.

To download the ALMS installation file from the Internet
1
Ensure you have logged into the target client PC as a user with “Administration” priveleges.
2
Start your Internet browser.  In the address box, type 
http://www.fs.fed.us/fire/planning/nist/distribu.htm , and then press Enter.

3
Scroll down to Software, and then double-click ALMSV3.0.0.

4 Double-click the installation file, and then save it in the folder of your choice.

For Forest Service users, save the ALMS_V3.exe file in C:\fsapps\fsprod\fam\ALMS  For all others, follow your agency’s guidelines.
5
The file ALMS_data.exe is also located in the Software folder.  This file  contains additional data layers that can be used with ALMS which includes federal lands boundaries.  ALMS is distributed with the default layers of Capitals, Counties, Freeways, Major Cities, and States.  You may download this zip file now or at a later time.

6
IF you downloaded ALMS_data.exe, navigate to the folder where you saved the file and doubl-click on the file.  Extract the files to a folder of your choice.  Forest Service users extract to c:\fsapps\fsprod\fam\alms\data.
To install ALMS V3.0
1
From your personal computer, locate the folder that contains the file ALMS_V3.exe.

2
Double-click ALMS_V3.exe.

3
Complete the installation process as instructed on your screen.

The following screen shows the first ALMS Installation dialog box.

[image: image2.png]InstaliShield Wizard

Preparing to Install

Autornated Lightning Mapping Syster v 3.0 Setup is preparing
the InstallShield Wizard, which wil guide you thraugh the
program setup process. Please wait

Checking Operating Syster Version

Cancel





The following screen shows the Welcome dialog box.  Click Next to continue the installation process.
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The following screen shows the Choose Destination Location dialog box.  Review the Destination Folder for the ALMS software, and then click Next to continue the installation process.  Press Change only if you would like to select a different destination folder.
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The next screen allows you to review the installation settings you have chosen.  Press Install to continue or Back to go to a previous screen and change a setting.
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As the installation continues, you will see the following screen.
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When the installation is complete, the following screen will display.  Click Finish to complete the installation.
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To configure your time zone on the BLM lightning data server

Perform this task only if you have not previously done so!
1
Start your Internet browser.

2
In the address box, type http://www.nifc.blm.gov, and then press Enter.

3
On the Wildland Fire Management Information Home Page, click Lightning.

4
On the BLM Lightning - Logon screen, type your Username and Password, and then click Logon.

5
On the BLM Lightning - Successful Logon screen, click User Preferences.

6
Under Time Zone Selection, select the appropriate Time Zone and Daylight Savings Time preference, and then click Update Preferences.

7
When finished, click Logoff, and then exit your Internet browser.

The following diagram shows the Wildland Fire Management Information Home Page.
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The following diagram shows the BLM Lightning - Logon screen.
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The following diagram shows the BLM Lightning - User Preferences screen.
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To set up ALMS 3.0 in ArcMap

When ALMS 3.0 was installed, an ALMS dll is registered and added as an extension to ArcMap.  The ALMS Tools toolbar is then available to be turned on within ArcMap.

Before starting this task, log off Lotus Notes to avoid potential memory conflicts.
1
Click Start, point to Programs, point to ArcGIS, and then click ArcMap.
2
Turn on the ALMS Tools toolbar by selecting View>Toolbars and select ALMS Tools.  You will see the toolbar pictured below.  The toolbar can be placed anywhere on your screen or into the header section with the other toolbar buttons.  To move the toolbar, left-click in the upper blue section, hold the mouse down and drag the toolbar to the desired location.
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3
From the ALMS toolbar, select ALMS>Set User Defaults.  The other ALMS Tools options will not function until the defaults are set.  You will be presented with the following screen.
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ALMS Defaults are specific to the Windows userid currently logged in.  Individual users must each initially set up their ALMS defaults. 
Enter the information required in the following sections and press OK when finished.  Press Cancel to exit this screen without saving any changes.

· User Information:  enter your BLM Lightning Server Username, and then type your BLM Lightning Server Password.  Remember the password is case sensitive.

· Download Data Path: Select the path where you would like the downloaded lightning data files to reside.

· Default Lightning Data Symbol: You may select Lightning, Dot or Box as the default symbols.  Also select a size for the symbol.  For advanced ArcMap users, this symbol could also be changed within ArcMap.

· Alms Default Environment: The items in this section are the basic settings required to map the lightning data.  If you are an advanced ArcMap user and are using the lightning data with an existing project or other data sources, you may want to keep your existing project settings.

· Set Albers US Data View Projection – checking this box sets or changes the data view projection for the project to Albers US Data.  Only check this if you do not have a projection already set and would like to use this projection for the ALMS data and any other data you are mapping in this project.
·  Add Default Alms Map Data – checking this box adds the default ALMS layers to your project.  The default layers are: Capitals, Counties, Freeways, Major Cities, and States.  If any of these layers already exist, the program will replace them only if they are newer.  Any other existing layers will not be affected.  Other data layers are available including federal boundaries and can be downloaded from http://www.fs.fed.us/fire/planning/nist/distribu.htm.

· Setup the Default ALMS Layout View – checking this box sets the layout view to a default view supplied by ALMS.  Checking this box will replace an existing layout view!!

 If you chose to Add Default Alms Map Data, a map showing the United States will be displayed.  Any layers that are not visible will be activated after zooming into the appropriate resolution.
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4 Save this map project before exiting.  Proceed to the Using ALMS section of this guide to begin mapping lightning data.

You have just successfully installed ALMS!  Next, complete the clean up task and then you are ready to use ALMS.
To clean up
1
On the Start menu, point to Programs, and then click Windows Explorer.

2
Open the folder that contains the install file ALMS_V3.exe.

3
Right-click ALMS_V3.exe, select Delete, and then click Yes.

To log off ALMS/ArcMap
• 
On the File menu, click Exit.

Terms and Concepts
This section identifies some of the key toolbars and menus that you will be using in ALMS 3.0.

Screen terminology
The following diagram shows the ArcMap/ALMS screen and screen elements.

 SHAPE  \* MERGEFORMAT 



ArcMap/ALMS Toolbar
The following diagram shows the buttons that are available on the ArcMap and ALMS toolbar.  Each button allows you to perform a specific function.  When you hover the mouse over a particular button, a description of that button’s function displays in a tool tip over or next to the button.
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For more information about using toolbar buttons, refer to your ArcMap user’s guide.
Using ALMS
This chapter explains some of the basic functions you can perform in ALMS.  Topics include:

• 
Starting ArcMap/ALMS application

• 
Downloading lightning data

• 
Setting the area of interest

• 
Perfoming Batch Imports

Starting ArcMap/ALMS
You may want to create a shortcut of ArcMap 8.3 to save time starting the application!
To start ArcMap/ALMS
1
Click Start, point to Programs, point to ArcGIS, and then click 
ArcMap.

2
Open the existing map that you saved during the installation steps or start with a new empty map.  If you start with a new empty map, you will need to go through setting the ALMs defaults again.  See the previous section, Getting Started>To set up ALMS 3.0 in ArcMap>Step 3 for instructions on setting ALMs Defaults.
3
If the ALMS Tools toolbar is not showing, on the View menu, click Toolbars and select ALMS Tools.

Adding Other Data Layers

To download additional ALMS data layers from the Internet

ALMS is distributed with the default layers of Capitals, Counties, Freeways, Major Cities, and States.  The additional layers available for download are: NPS Units, National Forests, FWS Units, and BLM Resource Management Units.  If you already downloaded ALMS_data.exe, then skip to step 6!
1
Start your Internet browser.

2
In the address box, type 
http://www.fs.fed.us/fire/planning/nist/distribu.htm, and then press Enter.

3
Scroll down to Software, and then click on ALMS_data.exe
4
Double-click the exe file, and then save it in the folder of your choice.  

5
Navigate to the folder where you saved the file and doubl-click on the file.  Extract the files to a folder of your choice.  Forest Service users extract to the default directory c:\fsapps\fsprod\fam\almsv3\data.
6
Return to ArcMap/ALMS.  Select File>Add Data.  

7
Browse to the folder where you extracted the layers and select the layers (.lyr files) you would like to add as shown in the screen below. 

ArcMap sets the projections for map layers “on the fly” to the projection set for the project as the data is added.  You may get warning messages if layers being added have a different projection than the one currently set by the project.   The warnings can usually be ignored as the layers will automatically be set to the current projection.
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Setting the Area of Interest

1
Click the red rectangle on the ALMS Toolbar.

2
Click, hold, and drag to create a rectangle around the area of your choice.

The screen below shows an Area of Interest created in western Montana.  If an area of interest is set prior to downloading lightning data, the download will only include data for the area delineated.  The area of interest is stored in the users profile and will remain set until it is changed.
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Download and Map Lightning data
To download lightning data
1
Click the yellow lightning symbol on the ALMS Toolbar or select ALMS>Download Data.  The following screen will be displayed.
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2
On the Lightning Data Download dialog box, enter the desired download parameters:

· Time Frame: The initial values are the Previous 2 Hours from the current date and time.  The values can be entered manually or adjusted using the “Previous 24 Hours”, “Previous 2 Hours” and “Now” buttons.  

· Bounding Rectangle:  Displays the upper and lower boundaries defined by the area of interest.  

· Polarity: Indicates polarity values that will be included in the datafile.  The default value is “Both”.  Click the botton next to the desired value.

· Status:  Indicates the status of the download as it progresses.

3
Click Download Data to begin the download.

The following screen shows the downloaded lightning data displayed on the map.
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Reviewing specific areas of interest
This section explains how to use toolbar buttons to review specific areas of interest.  Use these buttons in combination to quickly identify the specific area of your choice.

Using the zoom buttons
There are four different zoom buttons that you can use to navigate around the map:
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• 
The zoom buttons that show arrows pointing toward or away from a center point allow you to zoom in or zoom out from the center of the display.  These two buttons are on the first row of the toolbar.

[image: image24.png]*_Untitled - ArcMap - ArcView

=15x]

Fle Edit View Insert Selection Tools Window Help

DEES|4 B RX| oo e

& @aizades 9hon F

CEEIEEEEEE R
avsv |0 |

& & Layers A
£ B ALM5200310080903
et_hours
© 05-5.193hrs
* 5.193-9.887 hrs.
#9887 - 14.58 s,
# 14.58- 19.274 hrs
# 10,274 - 23.967 hrs
£ B Capitals
POP_CL, CAPITAL
* 7,500-25,000
* 25,000-100,000
# 50,000-100,000
P 100,000-500,000
@ 500,000-1,000,000
@ Over 1,000,000
& [ Major Cities
POP_CL, CAPITAL
- 25,000-100,000
© 50,000-100,000
® 100,000-500,000
® 500,000-1,000,000
® Over 1,000,000
& B NPS Units

£ @ National Forests
L

B & FWS Units
L]

5 @ BLM ResoLrce Managem
o

5 @ States

o
& [ Counties
o

=] Freeways -
B

Display [Source oG

Crawng > K OO~ A~ 2 |[aviel

Change to a different font

[ [1862548.91 -B36714.05 Meter|



• 
The zoom buttons that show a plus sign (+) or minus sign (-) within a magnifying glass allow you to zoom in or zoom out from a point you click on the map.  These two buttons are on the first row of the toolbar.

To zoom in or zoom out
• 
Click the zoom button of your choice, and then click on the map location of your choice.  Notice that various layers are defined as scale dependent and displayed as the map is zoomed in.

[image: image20.png]mxd - ArcMap - Arc

Fle Edit View Insert Selection Tools Window Help

SHSE| ) B@X |0 | [zmen

|2

[ole [

DOEDIER O M S

EE@\EED@DD =&

avsv |0 |

& & Layers

£ B ALM5200310071725
et_hours
0017-0.404 hrs,
0.404-0.79 hrs
0.79- 1177 hrs
1.177- 1563 s,
1.563- 195hrs,
Capitals

POP_CL, CAPITAL
* 7,500-25,000
* 25,000-100,000
# 50,000-100,000
P 100,000-500,000
@ 500,000-1,000,000
@ Over 1,000,000
Major Ciies

POP_CL, CAPITAL
- 25,000-100,000
© 50,000-100,000
® 100,000-500,000
® 500,000-1,000,000
® Over 1,000,000
S Urits

£ @ National Forests
L
B & FWS Units
L]
BLM ResoLrce Managem
o
5 @ States
o
5 @ Counties
[m]

5 @ Freeways =

1 b

Display [Source

Crawng> K O O~ A~ 2 |[avial

[-1322118.65 977096.23 Meters|





Performing Batch Import

The batch import utility can be used to import previously downloaded acii data files created via the external lightning down executable (lghtndown.exe).  

1
Select ALMS>Batch Import on the ALMS Toolbar.

2
Browse to the location of the data files using the Batch Import screen as shown below.  Select one or more files for import. 

3
Press OK to import.  The text files will be processed into shape files and other supporting files then displayed as layers in the project.
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